Напишите программу для решения следующей задачи: с клавиатуры вводятся 25 пар чисел....

0 голосов
70 просмотров

Напишите программу для решения следующей задачи: с клавиатуры вводятся 25 пар чисел. Вывести на экран только те пары, сумма которых больше 100


Информатика (89 баллов) | 70 просмотров
0

блин

0

не то скинул

0

l = [] # создание списка для хранения пар чиселfor i in range(25): # начало цикла n, m = map(int,input().split()) # ввод чисел if n + m > 100: # проверка условий l.append([n, m]) # добавление пары в списокfor i in l: print(*i) # вывод пар

0

во, то самое

0

@dimageorgiev2016, автор просил ответ на Pascal.

0

эт пайтон чтоль?

0

В любом случае, кому-то следует написать ответ

0

блин, так на паскале что-ли надо

0

Именно. Читайте то, что написано вначале комментариев.

0

i am sorry

Дано ответов: 2
0 голосов

Python 3:

l = [] # создание списка для хранения пар чисел

for i in range(25): # начало цикла

   n, m = map(int,input().split()) # ввод чисел

   if n + m > 100: # проверка условий

       l.append([n, m]) # добавление пары в список

for i in l:

   print(*i) # вывод пар

(50 баллов)
0 голосов
  1. const
  2.    N = 25;
  3. var
  4.    arr: array[1..N, 1..2] of real;
  5.    firstNumber, secondNumber: real;
  6.    i, j: integer;
  7. begin
  8.    for i := 1 to N do
  9.        begin
  10.            Readln(firstNumber, secondNumber);
  11.            
  12.            Writeln();
  13.            
  14.            if (firstNumber + secondNumber > 100) then
  15.                begin
  16.                    j := j + 1;
  17.                    
  18.                    arr[j, 1] := firstNumber;
  19.                    arr[j, 2] := secondNumber;
  20.                end;
  21.        end;
  22.    
  23.    Writeln();
  24.    
  25.    for i := 1 to j do
  26.        Writeln(arr[i, 1], ' | ', arr[i, 2]);
  27. end.
(5.6k баллов)