Напишите программу ** языке Паскаль. Определить, является ли число, введённое с...

0 голосов
36 просмотров

Напишите программу на языке Паскаль. Определить, является ли число, введённое с клавиатуры простым.


Информатика (52 баллов) | 36 просмотров
Дан 1 ответ
0 голосов

var n, i: integer;

begin

   write('Введите число: ');

   readln(n);

   i:=2;

   while n mod i <> 0 do

       i += 1;

   if i = n then

       writeln('Простое')

   else

       writeln('Не простое');

end.

(4.3k баллов)