Написать программу ** языке Паскаль для решения задачи. С помощью цикла с послеусловием...

0 голосов
38 просмотров

Написать программу на языке Паскаль для решения задачи. С помощью цикла с послеусловием напишите программу, которая требует у вас пароль, например, 111. Если пароль правильный, то заполняет все строки экрана сообщением «Молодец». Если после пятой попытки пароль все равно неверен, выходит из программы. Для проверки подготовить код программы и результаты ее работы.


Информатика (161 баллов) | 38 просмотров
Дан 1 ответ
0 голосов

Код программы:

(пароль: 105)

program raf105;

const pass = 105;

var enterpass, x:integer;

begin

repeat

 write('Введите пароль: ');

 readln(enterpass);

 if enterpass = pass

   then

     while 1=1 do

       writeln('Молодец')

   else x += 1;

until x=5;

end.

Результаты работы программы:

1.

Вывод: Введите пароль:

Ввод: 105

Вывод: Молодец Молодец Молодец Молодец Молодец Молодец Молодец Молодец Молодец...

2.

Вывод: Введите пароль:

Ввод: 123

Вывод: Введите пароль:

Ввод: 106

Вывод: Введите пароль:

Ввод: 0

Вывод: Введите пароль:

Ввод: 104

Вывод: Введите пароль:

Ввод: 666

(2.1k баллов)