Написать программу для решения задачи. Дана строка, содержащая текст ** русском языке, и...

0 голосов
37 просмотров

Написать программу для решения задачи. Дана строка, содержащая текст на русском языке, и некоторая буква. Подсчитать, сколько слов начинается с указанной буквы. Не копируйте существующие, не работают


Информатика (80 баллов) | 37 просмотров
Дан 1 ответ
0 голосов

program raf105;

var

 s:string;

 b:char;

 o,i:integer;

begin

write('Введите строку: ');

readln(s);

write('Введите искомую букву: ');

readln(b);

s:= lowercase(s);

b:= lowercase(b);

if s[1] = b

 then o+=1;

for i:=2 to length(s) do

 if (s[i]=b) and (s[i-1]=' ')

   then o+= 1;

writeln('С буквы "',b,'" начинается ',o,' сл.');

end.

Язык PascalABC

(2.1k баллов)