Программу требуется написать ** языке Pascal:Массив нужно заполнить вводом с...

0 голосов
52 просмотров

Программу требуется написать на языке Pascal:Массив нужно заполнить вводом с клавиатурыДан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от 0 до 100. Составьте программу, которая находит и выводит произведение двузначных элементов массива, которые не делятся на 6. Гарантируется, что в исходном массиве есть хотя бы один такой элемент.


Информатика (44 баллов) | 52 просмотров
0

Массив нужно заполнить вводом с клавиатуры или случайными числами от 0 до 100?

0

Сейчас уточню,минутку

0

Нужно заполнять вводом

Дан 1 ответ
0 голосов

program raf105;

var a:array[1..30] of integer;

pro,i:integer;

begin

writeln('Вводите 30 чисел по очереди');

pro:=1;

for i:=1 to 30 do

begin

 readln(a[i]);

 if (a[i] <= 99) and (a[i] >= 10) and ((a[i] mod 6) <> 0)

   then pro*= a[i];

end;

writeln('Вывод: ',pro);

end.

(2.1k баллов)
0

Огромное спасибо!! Я очень благодарен!

0

Только почему то выдает ошибку на 17 строке "Неожиданный символ"

0

Так получается при копировании со страницы этого сайта

0

Удалите все пробелы перед некоторыми строками кода и ошибки быть не должно

0

А,спасибо,все хорошо