Язык паскаль, можно через while Написать программу, в которой осуществляется ввод целых...

0 голосов
23 просмотров

Язык паскаль, можно через while Написать программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор пока не будет введён ноль) и подсчёт суммы введённых положительных чисел. Используйте оператор repeat


Информатика (34 баллов) | 23 просмотров
Дан 1 ответ
0 голосов

Ответ:

Объяснение:

Pascal

var a,i,s,n:integer;

begin

 s:=0;

 n:=0;

 repeat

    readln(a);

    if a>0 then begin

       n:=n+1;

       s:=s+a;

    end;

 until a = 0;

 writeln('Сумма ',s:5,'  Среднее арифметическое ',s/n);

end.

(335 баллов)