Задание по программированию ** С++ Написать программу, которая будет выводить ** экран:...

0 голосов
82 просмотров

Задание по программированию на С++ Написать программу, которая будет выводить на экран: «Введи свой возраст», затем считывать введенное с клавиатуры целое число и выводить на экран правильно законченную фразу: «Вам !число! год/года/лет», если число находиться в промежутке (1-130), обработать возможные ошибки


Информатика (1.0k баллов) | 82 просмотров
Дан 1 ответ
0 голосов

#include

using namespace std;

int main(){

setlocale(LC_ALL, "Russian");

cout<<"Введи свой возраст"<<endl;</p>

int a;

cin>>a;

if (a<1||a>130){cout<<"Введено некорректное значение"; return 0;}</p>

if (a%100==11||a%100==12||a%100==13||a%100==14){cout<<"Вам "<<a<<" лет"; return 0;}</p>

if (a%10==1){cout<<"Вам "<<a<<" год"; return 0;}</p>

if (a%10==2||a%10==3||a%10==4){cout<<"Вам "<<a<<" года"; return 0;}</p>

cout<<"Вам "<<a<<" лет";</p>

return 0;

}

_________

Есть еще возможность проверки принадлежности введеной строки к числовому типу. Но, просматривая уровень ваших заданий, я пришел к выводу, что функции такого уровня будут не совсем желательны. Если все-же нужна - пишите.

(3.5k баллов)