8 задание, написать программу в Паскале, пожалуйста

0 голосов
22 просмотров

8 задание, написать программу в Паскале, пожалуйста


image

Информатика (159 баллов) | 22 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var a,b,x,y,z: real;

begin

writeln('Введите a, b и x');

readln(a,b,x);

if a=b then begin

y:=a*x;

z:=a/x;

end

else begin

y:=b*x;

z:=b/x;

end;

writeln('y = ',y:5:2,' z = ',z:5:2);

end.

Пример:

Введите a, b и x

9 2 5

y = 10.00 z =  0.40

PS. Задача 8 составлена так, что может быть решена без условного оператора:

var a,b,x,y,z: real;

begin

writeln('Введите a, b и x');

readln(a,b,x);

y:=b*x;

z:=b/x;

writeln('y = ',y:5:2,' z = ',z:5:2);

end.

(194k баллов)