Написать программу на языке программирования Паскаль: Найти наибольшую цифру натурального числа. С клавиатуры вводится натуральное число. Найти его наибольшую цифру. (Например, введено число 124653. Наибольшая цифра в нем 6).
Var
N,A:integer;
Begin
Write('N = ');Read(N);
A:=0;
While N>0 do
if (N mod 10) > A then A:= N mod 10;
N:=N div 10;
End;
Write(A)
End.
N,A,B:integer;
C:boolean;
A:=-1;
B:=-2;
C:=false;
if A=B then C:=true;
if N>0 then
A:=N mod 10;
B:=N mod 10;
if C then Write('Есть')
else Write('Нет')