Написать программу на языке Pascal с использованием цикла, так , чтобы программа по итогу выполнилась один раз, но при повторном запуске выдавала ошибку.
Ответ:
var x,y:integer;
z:real;
begin
readln(a);
y:=2;
z:=0;
while y>0 do begin
y:=y-1;
z:=x/y;
writeln(z)
end;
end.
Объяснение:
При первой прокрутке цикла программа выполнится. При повторной прокрутке b станет равным нулю и будет деление на ноль, на что паскаль выдаст ошибку.