Напишите программу для решения следующей задачи. ** контрольной работе по алгебре...

0 голосов
479 просмотров

Напишите программу для решения следующей задачи. На контрольной работе по алгебре ученикам 9 класса было предложено 10 примеров. Неудовлетворительная оценка выставляется, если правильно решено менее половины примеров. Сколько неудовлетворительных оценок было получено учениками? Если хотя бы один из учеников правильно решил все задачи, выведите YES, иначе выведите NO. Программа получает на вход количество учеников в классе N (1 ≤ N ≤ 30), затем для каждого ученика вводится количество правильно решённых примеров.


Информатика (104 баллов) | 479 просмотров
0

RFRJQ ZPSR,

0

Какой язык?

Дан 1 ответ
0 голосов

Написано на с++

//WlAY...

#include

using namespace std;

int main()

{

   int N;

   cout << "Введите число учеников ->";

   cin >> N;

   if (N < 1)

   {

       cout << "ОШИБКА(учеников меньше 1)" << endl;</p>

   }

   if (N > 30)

   {

       cout << "ОШИБКА(учеников  больше 30)" << endl;</p>

   }

   else

   {

       int b[N];

       int i;

       int n1 = 0, n2 = 0, n3 = 0;

       for (i = 0; i <= N - 1; i++)</p>

       {

           cout << "Введите кол-во правильно решённых примеров ученика номер" << i + 1 << "->";

           cin >> b[i];

           if (b[i] == 10)

               cout << "ОШИБКА(заданий всего 10)";</p>

           if (b[i] == 10)

               n1 += 1;

           if (b[i] < 10 && b[i] >= 5)

               n2 += 1;

           if (b[i] < 5)

               n3 += 1;

       }

       cout << "---------------------ИТОГ-------------------------" << endl;</p>

       cout << n1 << " ученик(а, ов) решил(и) все задания правильно (YES)" << endl;</p>

       cout << n2 << " ученик(а, ов) получил(и) удовлетворительную оценку (NO)" << endl;</p>

       cout << n3 << " ученик(а, ов) получил(и) неудовлетворительную оценку (NO)" << endl;</p>

   }

}


image
(14 баллов)