Напишите программу, которая вводит возраст человека (целое число, не превышающее 120) и...

0 голосов
286 просмотров

Напишите программу, которая вводит возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом "год" "года" или "лет". Например "21 год" "22 года" "25 лет"


Информатика (23 баллов) | 286 просмотров
0

Напишите программу, которая определяет, верно ли, что введённое число трёхзначное.

0

a:integer;if (a>99) and (a<1000)все))

0

Напишите программу, которая вводит целое число, не превышающее 100, и выводит его прописью, например: 21- "двадцать один"

Дан 1 ответ
0 голосов

Program years;
year:integer;
begin
readln(year);
if(year >0) and(year<=120) then begin<br>if(year mod 10 =0)or(year mod 10 >=5) then writeln(year, ' лет ')
else if(year mod 10 =1)then writeln(year, ' год ')
else writeln(year, ' года ');
end;
end.

(803 баллов)
0

Напишите программу, которая определяет, верно ли, что введённое число трёхзначное.