Написать программу:Ввести символ. Вывести строку трех подряд идущих в алфавите символов:...

0 голосов
40 просмотров

Написать программу:Ввести символ. Вывести строку трех подряд идущих в алфавите символов: предыдущего, текущего и последующего. Пример: Вход: d Выход: cde


Информатика (24 баллов) | 40 просмотров
0

Какой язык и формат ввода?

0

с++ char

0

вводится символ в алфавите от b до y?

0

да

Дан 1 ответ
0 голосов

Ответ:

Снизу код:

Объяснение:

#include

using namespace std;

int main()

{

   char a;

   char b;

   char c;

   cin >> a;

   b = a - 1;

   c = a + 1;

   cout << b;</p>

   cout << a;</p>

   cout << c;</p>

}

UPD: когда заводишь переменную char то если в этот чар забить число выведется символ например: char a = 49 если вывести a получится 1. таблица ASCII в помощь

(274 баллов)