ОЧЕНЬ СРОЧНО НАДО, написать программу ** языке программирования Pascal!!!! С клавиатуры...

0 голосов
16 просмотров

ОЧЕНЬ СРОЧНО НАДО, написать программу на языке программирования Pascal!!!! С клавиатуры вводится рост 20 учащихся 8 класса. Определить средний рост учащихся 8 класса.


Информатика (16 баллов) | 16 просмотров
Дано ответов: 2
0 голосов

program Project1;

const

 maxelem = 100;

var

 a: array [1..maxelem] of integer; { Переменная для  хранения массива.}

 n: integer; {  Переменная для хранения значения количества элементов в массиве.}

 i,k: integer; { Вспомогательные переменные для организации циклов.}

 sum: integer; {  Переменная для хранения значения суммы выбранных величин роста}

begin

 n:= 15;

 for i:= 1 to n do

   repeat

     write('Введите значение ',i,' элемента: ');

     Readln(a[i]);

     if (a[i] < 150) or (a[i] > 200) then

       writeln('Введенное число не входит в заданный диапазон.');

   until (a[i] >= 150) and (a[i]

 writeln('Исходный массив: ');

 for i:= 1 to n do

   begin

     write(a[i]:5);

     if i mod 10 = 0 then

       writeln;

   end;

 sum:= 0;

 k:= 0;

 for i:= 1 to n do

   if a[i] > 180 then

     begin

       sum:= sum + a[i];

       inc(k);

     end;

 writeln;

 if k = 0 then

   writeln('В классе нет учеников с ростом выше 180 см.')

 else

   writeln('Средний рост игроков баскетбольной команды: ',(sum/k):0:2);

 Readln;

end.

(146 баллов)
0

спасибо:3

0 голосов

Ответ:

program z1;

var

 q, w, e, r, t, y, u, i, o, p, a, s, d, f, g, h, j, k, l, z: integer;

begin

 writeln('Введите рост 1 учащегося');

 readln(q);

 writeln('Введите рост 2 учащегося');

 readln(w);

 writeln('Введите рост 3 учащегося');

 readln(e);

 writeln('Введите рост 4 учащегося');

 readln(r);

 writeln('Введите рост 5 учащегося');

 readln(t);

 writeln('Введите рост 6 учащегося');

 readln(y);

 writeln('Введите рост 7 учащегося');

 readln(u);

 writeln('Введите рост 8 учащегося');

 readln(i);

 writeln('Введите рост 9 учащегося');

 readln(o);

 writeln('Введите рост 10 учащегося');

 readln(p);

 writeln('Введите рост 11 учащегося');

 readln(a);

 writeln('Введите рост 12 учащегося');

 readln(s);

 writeln('Введите рост 13 учащегося');

 readln(d);

 writeln('Введите рост 14 учащегося');

 readln(f);

 writeln('Введите рост 15 учащегося');

 readln(g);

 writeln('Введите рост 16 учащегося');

 readln(h);

 writeln('Введите рост 17 учащегося');

 readln(j);

 writeln('Введите рост 18 учащегося');

 readln(k);

 writeln('Введите рост 19 учащегося');

 readln(l);

 writeln('Введите рост 20 учащегося');

 readln(z);

 writeln('Средний рост учащихся ', (q + w + e + r + t + y + u + i + o + p + a + s + d + f + g + h + j + k + l + z) / 20, ';');

end.

(534 баллов)