СРОЧНО!!! НАПИСАТЬ ТОЛЬКО ** РУССКОМ!!!Вариант 4. №1. Напишите программу, которая в...

0 голосов
65 просмотров

СРОЧНО!!! НАПИСАТЬ ТОЛЬКО НА РУССКОМ!!!Вариант 4. №1. Напишите программу, которая в последовательности натуральных чиселопределяет сумму чисел, кратных 7.Программа получает на вход количество чисел в последовательности, азатем сами числа. В последовательности всегда имеется число, кратное 7.Количество чисел не превышает 100. Введённые числа не превышает 300.Программа должна вывести одно число — сумму чисел, кратных 7.​


image

Информатика (48 баллов) | 65 просмотров
Дан 1 ответ
0 голосов

#include

#include

#include

#pragma GCC optimize("Ofast")

#define ll long long

#define ld long double

using namespace std;

signed main() {

  ll n;

  cin >> n;

  ll sum = 0;

  while(n--){

      ll x;

      cin >> x;

      if(x % 7 == 0)

          sum += x;

  }

  cout << sum;</strong>

}

(670 баллов)