Помогите плиз эту задачу нам дали из электива по информатики начинаться должно так...

0 голосов
71 просмотров

Помогите плиз эту задачу нам дали из электива по информатики начинаться должно так Program abc;
var a,b,c:integer;
Begin и дальше пож


Информатика (27 баллов) | 71 просмотров
0

вот задача Написать программу нахождения числа(из трех),которое находится посередине.

0

ввод чисел с клавиатуры?

0

да

0

напиши пож

0

по середине - это типо если ввел 4,8,2,то по серидине 4? (если упорядочить)

0

ну да токо не числа как бы то а по английски a,b,c и по середине а должна быть

Дано ответов: 2
0 голосов
Правильный ответ

Var a,b,c:integer;
BEGIN
     writeln('Введите числа');
     readln(a,b,c);
     If ((a>b) and (b>c)) or ((c>b)and(b>a)) then writeln('число по середине b=',b);
     if ((a>c) and (c>b)) or ((c>a)and(b>c)) then writeln('число по середине c=',c);
     if ((b>a) and (a>c)) or ((a>b)and(c>a)) then writeln('число по середине a=',a);
     readln;
END.

(30.1k баллов)
0 голосов

Var a,b,c:integer;
BEGIN
readln(a,b,c);
writeln('Ваше число равняется ');
writeln(b);
END.

Я так понял

(237 баллов)
0

Ты можешь получше расписать, но эта запись компактнее