** языке программирования Паскаль напишите программу нахождения суммы натурального ряда...

0 голосов
56 просмотров

На языке программирования Паскаль напишите программу нахождения суммы натурального ряда нечетных чисел от 1 до N


Информатика (822 баллов) | 56 просмотров
0

заводишь переменную со значением 0 и for'ом от 1 до N проходишь и прибавляешь к той переменной значение перемнной цикла

0

я не могу , поэтому и написала сюда

0

ну если бы не Паскаль, а нормальный язык, то я бы написал прям код, но в этом случае написал общий алгоритм решения и желаю вам удачи

Дан 1 ответ
0 голосов

var

i,n,s:integer;

Begin

s:=0;

Readln(n);

for i:=1 to n do

 if i mod 2=1 then s+=i;

Writeln(s);

end.

(180 баллов)