Помогите написать программу ** C++ Оформить функцию поиска количества нулевых элементов...

0 голосов
50 просмотров

Помогите написать программу на C++ Оформить функцию поиска количества нулевых элементов массива. В главной программе дано 3 одномерных массива arr1,arr2,arr3 длиной 10 элементов каждый. Применить функцию для каждого из 3-х заданных массивов. (в функции не должно быть операторов ввода или вывода)


Информатика (48 баллов) | 50 просмотров
0

Массивы заполнять рандом, ручками или хардкод?

0

рандомно

0

Ок

0

Содержимое самих массивов на экран надо выводить?

0

да

0

спасибо большое

0

Возможно что - то еще нужно?

0

нет спасибо главное ответ правильный

Дан 1 ответ
0 голосов

Ответ:

#include

using namespace std;

#define n 10

void fillingMass(int arr[n])

{

   for(int i=0; i

   {

       arr[i] = -5 + rand() % 10;

       cout<<arr[i]<<" "; // вывод содержимого массивов, если не надо уберешь</p>

   }

   cout<<endl; // вывод содержимого массивов, если не надо уберешь</p>

}

int countingZero(int arr[n])

{

   int count = 0;

   for(int i=0; i

   {

       if(arr[i] == 0)

           count++;

   }

   

   return count;

}

int main()

{

   int arr1[n],arr2[n],arr3[n];

   fillingMass(arr1);

   fillingMass(arr2);

   fillingMass(arr3);

   

   cout<<"In the first array, the number of zero elements = "<<countingZero(arr1)<<endl;</p>

   cout<<"In the second array, the number of zero elements = "<<countingZero(arr2)<<endl;</p>

   cout<<"In the third array, the number of zero elements = "<<countingZero(arr3)<<endl;</p>

   return 0;

}

Объяснение:


image
(4.0k баллов)