Здравствуйте, помогите с заданиями по информатике! 1. Составить программу нахождения...

0 голосов
22 просмотров

Здравствуйте, помогите с заданиями по информатике! 1. Составить программу нахождения минимального элемента и его номера в массиве вещественных чисел не более 50, задаваемых вводом с клавиатуры. 2. Сформировать массив (вывести на экран) из т случайных целых чисел на промежутке от -60 до 60, найти сумму чисел больших 20. 3. В массиве подсчитать количество элементов больших, чем 13. Элементов в массиве 14. Целочисленный массив вводится случайным образом в интервале от 3 до 30.


Информатика (17 баллов) | 22 просмотров
0

язык?

0

Pascal

0

сочувствую

0

ага, спасибо

Дан 1 ответ
0 голосов

Ответ:

готово

Объяснение:

1)

program minimum;

var

 i, n, k: integer;

 min: real;

 A: array of real;

begin

 Write('Введите размер массива: ');

 ReadLn(n);

 SetLength(A, n);

 for i := 0 to n - 1 do

 begin

   Write('Введите A[',i,']=');

   ReadLn(A[i]);

 end;

 min := A[0];

 for i := 1 to n - 1 do

 if A[i] < min then

   begin

     min := A[i];

     k := i;

   end;

 WriteLn('Минимальный элемент - A[',k,'] = ', min);

end.

2)

program summa;

var

 i, t, sum: integer;

 A: array of integer;

begin

 Write('Введите размер массива: ');

 ReadLn(t);

 SetLength(A, t);

 for i := 0 to t - 1 do

 begin

   A[i] := round(random(120) - 60);

   WriteLn('A[', i, '] = ', A[i]);

   if A[i] > 20 then sum := sum + a[i];

 end;

 WriteLn('Сумма чисел, больших 20 = ', sum);

end.

3)

program massiv;

var

 i, k: integer;

 A: array[0..13] of integer;

begin

 for i := 0 to 13 do

 begin

   A[i] := round(random(27) + 3);

   WriteLn('A[', i, '] = ', A[i]);

   if A[i] > 13 then k := k + 1;

 end;

 WriteLn('Количество чисел, больших 13 равно ', k);

end.

(1.0k баллов)
0

спасибо, но можно попросить вас перерешать подобным образом первую задачу:

0

Var M:array[1..40] of integer; I, a, n, k:integer;
Begin
Writeln (‘Введите количество элементов массива, не более 40’); readln (n);
For i:=1 to n do m[i]:=random(201)-100;
For i:=1 to n do writeln (m[i]); k:=1;
a:=m[1]; For i:=2 to n do If m[i]>a then begin a:=m[i];k:=I end;
Writeln (‘Наибольший элемент=’, a ,’его номер’,k);
End.

0

всё нужно решить через array