PASKAL1) Написать программу с циклом. Дана переменная "n", написать программу где все...

0 голосов
24 просмотров

PASKAL
1) Написать программу с циклом.
Дана переменная "n", написать программу где все значения "n" будут суммироваться пока n не будет равно 1
2) Написать программу с циклом.
Дана переменная e, нужно выводить "e" в квадрат до тех пор пока "e" не будет равно 100
--------------
program test;
var..
begin


Информатика (35 баллов) | 24 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
    i, n, s: integer;

begin
    read(n);
    for i := n downto 1 do
        s := s + i;
    writeln(s);
end.

2)
var
    i, e: integer;

begin
    write('e = ');
    readln(e);
   
    if e > 100 then
        for i := e downto 100 do
            writeln(i * i)
    else
        for i := e to 100 do
            writeln(i * i);
end.


(53.1k баллов)
0

не заметила что там есть вывод, да каак раз им и пользуюсь, но в середине ничего не обьявляю

0

конечно неудобно, если скажем переменная нужна только в цикле, а обьявлять ее приходится на большее пространство, это не правильно как по мне

0

так сколько ж блин этих функции будет да и зачем?

0

поняла что локальные надо обьявлять

0

и тебе)))