Написать программу ** языке Паскаль, которая получает ** вход (вы вводите с клавиатуры)...

0 голосов
31 просмотров

Написать программу на языке Паскаль, которая получает на вход (вы вводите с клавиатуры) трехзначное число, а затем однозначное, программа проверяет, есть ли однозначное число в трехзначном в виде одной из его цифр, программа должна вывести ответ на экран "да есть" или "такой цифры нет" Выполняя это задание назовите любую из переменных своим именем.


Информатика (17 баллов) | 31 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Ответ:

var trehznachnoe,odnoznachnoe: integer;

begin

write('Введите трехзначное число, а затем однозначное: ');

readln(trehznachnoe,odnoznachnoe);

if (trehznachnoe mod 10 = odnoznachnoe) then

writeln('да есть')

else if ((trehznachnoe div 10) mod 10 = odnoznachnoe) then

writeln('да есть')

else if ((trehznachnoe div 100) mod 10 = odnoznachnoe) then

writeln('да есть')

else writeln('такой цифры нет');

end.

(2.5k баллов)
0 голосов

===== PascalABC.NET =====

begin

 var Глебов := ReadInteger('Введи трехзначное положительное число:');

 var Цифра := ReadInteger('Введи цифру от 0 до 9:');

 while Глебов > 0 do

 begin

   if Цифра = Глебов mod 10 then

   begin

     Print('да, есть');

     exit

   end;

   Глебов := Глебов div 10

 end;

 Print('такой цифры нет')

end.

(1.6k баллов)