Составить Блок - Схему, и написать программу. Даю 50 баллов

0 голосов
29 просмотров

Составить Блок - Схему, и написать программу. Даю 50 баллов


image

Информатика (81 баллов) | 29 просмотров
0

Какой язык программирования?

0

паскаль

Дан 1 ответ
0 голосов

Ответ:

1.

var n1,n2,n3: integer;

begin

writeln('Введите n1,n2,n3: ');

readln(n1,n2,n3);

if (n2

if (n3

if (n3

writeln('n1,n2,n3 в возрастающем порядке: ',

n1,' ',n2,' ',n3);

end.

2.

var a,b,c: integer;

var s: real;

begin

writeln('Введите a,b,c: ');

readln(a,b,c);

s:=(a-b-c)/(sqrt(a*b*c));

writeln(s);

end.

3.

var a,b,c: integer;

var s: real;

begin

writeln('Введите a,b,c: ');

readln(a,b,c);

s:=(a+b+c)/3;

writeln('Среднее арифметическое: ',s);

end.

4.

var a,b: integer;

var s: real;

begin

writeln('Введите a,b: ');

readln(a,b);

if ((a>0) and (b>0)) then s:=a+b

else s:=a*a-b*b;

writeln(s);

end.


image
image
image
image
(2.5k баллов)
0

спасибо