Помогите написать программу ** С++.Составить программу для решения следующей задачи....

0 голосов
19 просмотров

Помогите написать программу на С++.
Составить программу для решения следующей задачи. Одноклеточная амеба каждые 3 часа делится на 2 клетки. Определить, сколько клеток образуется через N часов


Информатика (44 баллов) | 19 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
using namespace std;
int main()
{
    int N;
    int cells = 1;
    cout << "N = ";<br>    cin >> N;
    N = N / 3;
    for(int i = 0; i < N; i++)
    {
        cells *= 2;
    }
    cout << "Result: ";<br>    cout << cells;<br>    return 1;
}

(2.8k баллов)