Помогите. Напишите программу,которая вычисляет площадь кольца,если его толщина t см,а диаметр внутреннего круга - d.
Ответ:
program ring;
var t, d: real;
begin
write('Введите толщину и диаметр внутреннего круга >> ');
readln(t, d);
writeln(0.785*(sqr(d+t)-d*d)); //3.14*sqr(d+t)/4-3.14*d*d/4 = 0.785*(sqr(d+t)-d*d) (3.14/4 вынес за скобки)
end.