Здравствуйте ПОМОГИТЕ СРООЧНО!!! ПОЖАЛУЙСТА ИНФОРМАТИКА!!! Задача 1. Составить...

0 голосов
39 просмотров

Здравствуйте ПОМОГИТЕ СРООЧНО!!! ПОЖАЛУЙСТА ИНФОРМАТИКА!!! Задача 1. Составить программу для вычисления произведения N чисел. Задача 2. Дано целое число n. Вычислить значение факториала n! Теория: Рассмотрим, чему равняется 3! (факториал): P=3*2*1=6 Еще один пример: 5!: Р=5*4*3*2*1=120


Информатика (12 баллов) | 39 просмотров
0

язык программирования?

Дан 1 ответ
0 голосов

Ответ:

1)var n,i,sum: integer;

a: array [1..1000] of integer;

begin

writeln('Введите кол-во чисел N: ');

read(n);

sum:=1;

for I:= 1 to n do  

sum:=sum*i;

write('Произведение всех чисел = ',sum);

end.

2)var

 n, i, s: integer;

begin

 read(n);

 s := 1;

 for i := 1 to n do

   s := s * i;

 writeln(s);

end.

Объяснение:

(83 баллов)