Паскаль, 9 класс Написать программу, которая вводит массив из N вещественных чисел, а...

0 голосов
89 просмотров

Паскаль, 9 класс Написать программу, которая вводит массив из N вещественных чисел, а затем меняет местами наибольший и наименьший элементы массива. Протестировать программу на трѐх произвольных тестах


Информатика (22 баллов) | 89 просмотров
Дан 1 ответ
0 голосов

Pascal ABC

Код:

var

  a: array [1..100] of real;

  max, i, min, N: integer; temp: real;

begin

    readln(N);

    //заполнение массива и его вывод

    for i := 1 to N do begin

        a[i]:=random()*100;

        write(a[i]:0:2, ' ');

    end;

    writeln;

    //поиск максимума и минимума

    min := 1; max := 1;

    for i := 1 to N do begin

        if a[min] > a[i] then min := i;

        if a[max] < a[i] then max := i;

    end;

    //меняем местами

    temp := a[max];

    a[max] := a[min];

    a[min] := temp;

    //вывод массива

    for i := 1 to N do

        write(a[i]:0:2, ' ');

    writeln;

end.

Тесты:

Ввод:

5

Вывод:

81.57 14.35 20.60 42.20 21.09  

14.35 81.57 20.60 42.20 21.09

Ввод:

6

Вывод:

90.94 46.30 24.40 99.34 12.02 69.05  

90.94 46.30 24.40 12.02 99.34 69.05

Ввод:

4

Вывод:

52.21 61.47 17.57 68.80  

52.21 61.47 68.80 17.57

(388 баллов)
0

Ваааау :0 СПАСИБО ОГРОМНОЕЕЕЕЕЕЕЕЕЕЕЕ