Помогите пожалуйста. Написать программу, которая вводит двумерный массив 3х3, выводит его...

0 голосов
105 просмотров

Помогите пожалуйста. Написать программу, которая вводит двумерный массив 3х3, выводит его на экран в виде матрицы, а затем выводит количество отрицательных элементов. Я программу написала, но не понимаю, где ошибка program mas2; const m=3; n=3; var i, j, c: Integer; a: array [1..m, 1..n] of Integer; begin for i := 1 to m do for j := 1 to n do read (a[i,j]); for i := 1 to m do begin for j := 1 to n do write (a[i,j]:6); writeln; c := 0; if a[i, j] < 0 then c:=c+1; end; WriteLn('Количество отрицательных элементов равно ', c); end.


Информатика (12 баллов) | 105 просмотров
Дан 1 ответ
0 голосов

Вы забыли поместить команды цикла в блок "begin-end", а также зачем-то внутри цикла каждый раз обнуляли переменную c. Взгляните на исправленный вариант:

program mas2;

const

m=3;

n=3;

var

i, j, c: Integer;

a: array [1..m, 1..n] of Integer;

begin

for i := 1 to m do

for j := 1 to n do

read (a[i,j]);

c := 0;

for i := 1 to m do

begin

for j := 1 to n do

begin  

write (a[i,j]:6);

if a[i, j] < 0 then

c:=c+1;

end;

writeln;

end;

WriteLn('Количество отрицательных элементов равно ', c);

end.


image
(2.5k баллов)
0

Спасибо большое! Особенно за комментарий к ошибке, очень помогли.