2. Задача ** While. Написать программу, которая считает сумму случайных чисел в...

0 голосов
23 просмотров

2. Задача на While. Написать программу, которая считает сумму случайных чисел в диапазоне от-50 до 50 до тех пор, пока случайное число не выпадет равным 10. Полученную сумму вывести на экран монитора 3. Написать программу, которая перебирает все трехзначные числа и выводит на экран только те, которые кратны 5. Если можно пожалуйста решите без сложных команд) по типу как первое решено 1. (Задача на if) Запросить радиус круга R и сторону квадрата А. Определить, поместится ли круг в квадрате. Круг поместится в квадрате, если диаметр круга меньше или равен стороне квадрата. a=int(input('введите сторону квадрата')) r=int(input('введите радиус окружности')) d=2*r if d<=a: print('поместится') else: print ('не поместится')


Информатика (654k баллов) | 23 просмотров
Дан 1 ответ
0 голосов

2)

import random

k = 0

while True:

   x = random.randint(-50, 50)

   if x == 10:

       break

   else:

       k += x

print(k)

3)

for i in range(100, 1000, 5):

   print(i, end = ' ')

(34 баллов)