ПИТОН Напишите программу, которая заполняет массив из 10 элементов случайными числами в...

0 голосов
1.2k просмотров

ПИТОН Напишите программу, которая заполняет массив из 10 элементов случайными числами в диапазоне [100,500] и выводит его на экран. После этого на экран выводятся суммы цифр всех чисел, записанных в массив.Пример:Массив: 162 425 340 128 278 195 326 414 312 177 Суммы цифр: 9 11 7 11 17 15 11 9 6 15


Информатика (88 баллов) | 1.2k просмотров
Дан 1 ответ
0 голосов

Ответ:

import random

def sum_number(number:int) -> int:

   return sum(int(i) for i in list(str(number)))

array = [random.randint(100,500) for i in range(10)]

print(*array)

[print(sum_number(item), end = ' ') for item in array]

Объяснение:

(1.6k баллов)
0

что такое array?

0

просто имя переменной. Переводится как "массив"

0

спс

0

не работает

0

не складывает

0

я проверял её, у меня она работала. Вот скриншот вывода: http://prntscr.com/rywtq2

0

я никогда не кидаю людям недоделанные или работающие через раз решения