Информатика, 9 класс
1.Выберите правильное описание переменной типа массив:
1) var a:array[1…10] of integer;3) var a:array[1..10] of integer;
2) var a:array[1-10] of integer; 4) var a:array[1,10] of integer;
2.Массив – это:
1) совокупность разнородных данных, обрабатываемых как одно целое;
2) именованный набор однотипных данных на диске;
3) поименованный набор фиксированного числа однотипных данных;
4) набор одинаковых переменных.
3.Найдите верное обозначение элемента одномерного массива:
1) a[1.2]2) a[1,2]3) a(10) 4) a[10]
4.Задан следующий массив: A={10,5,-8,3,13,8,6}. Чему равна сумма третьего и шестого элементов массива:
1) 92) 03) 104) 35) 6
5.Число в каком диапазоне сформируется в результате следующей команды:
a[i]:=random(120);
1) от 1 до 1202) от 0 до 120 3) от 0 до 119 4) от 1 до 119
6.Чему будет равно значение элемента массива A[6] при выводе его на экран?
var i:integer; A:array[1..15] of integer;
begin
for i:=1 to 15 do A[i]:=i+i*2-10;
writeln(A[6]);
end.
1) 32 2) -7 3) 35 4) 8
7.Чему равна сумма второго и седьмого элементов массива, полученного в результате выполнения следующей программы?
var i,S:integer; A:array[1..10] of integer;
begin
A[1]:=4;
for i:=2 to 10 do A[i]:=A[i-1]+3;
S:=A[2]+A[7]; writeln(S);
end.
1) 29 2) 35 3) 34 4) 31
8.Чему будет равен элемент A[3] при выводе на экран?
var i,n,k:integer; A:array[1..5] of integer;
begin
n:=1; k:=10;
for i:=1 to 5 do A[i]:=k*i-n;
A[2]:=A[5]; A[4]:=A[2]+1; A[3]:=A[4];
writeln(A[3]);
end.
1) A[3]=492) A[3]=503) A[3]=394) A[3]=51
9.Как с помощью функции random(x) получить диапазон чисел от –30 до 30?