Очень срочно! Дорогие информатики, помогите! Паскаль abc

0 голосов
38 просмотров

Очень срочно! Дорогие информатики, помогите! Паскаль abc


image

Информатика (40 баллов) | 38 просмотров
Дан 1 ответ
0 голосов

Ответ:1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

uses crt;

var

i,n,k:integer;

a:array[1..100] of integer;

begin

writeln('введите числа последовательности. Окончанием ввода будет число 0');

i:=0;

n:=0;

repeat

i:=i+1;

n:=n+1;

read(a[i]);

write(' ');

until (a[i]=0) or (i>1000);

writeln;

k:=0;

writeln('Последовательность:');

for i:=1 to n-1 do

begin

write('a[',i,']=',a[i],' ');

if ((a[i] mod 2)=0) and ((a[i] mod 7)=0) then

k:=k+1;

end;

writeln('кол-во целых чётных чисел кратных 7 - ',k);

end.

Второй вариант : 1

2

3

4

5

6

7

8

9

10

11

12

13

14

uses crt;

var k,n: integer;

begin

write('vvedite chislo ');

readln(n);

if (n mod 7=0) and (n mod 2=0) then inc(k);

while n<>0 do

     begin

     write('vvedite chislo ');

     readln(n);

     if (n mod 7=0) and (n mod 2=0) then inc(k);

     end;

writeln(k-1);

end.

3 ВАРИАНТ :

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

const

 lim1=30000;

 lim2=1000;

var

 a,kol,res:integer;

begin

 kol:=0;

 res:=0;

 repeat

   repeat

     readln(a);

     if abs(a)>lim1 then

       writeln('Oshibka vvoda. |a|

   until abs(a)

   if a<>0 then

     begin

       inc(kol);

       if (a mod 2=0) and (a mod 7=0) then

         inc(res);

     end;

 until (a=0) or (kol=lim2);

 write(res);

end.

(58 баллов)
0

Задача в прикреплённой фотографии, нужно составить программу