Написать программу ** языке Паскаль у=2sin3x-12x/

0 голосов
57 просмотров

Написать программу на языке Паскаль у=2sin3x-12x/


Информатика (12 баллов) | 57 просмотров
0

Формула в задании так и записана? Просто мне кажется, что не хватает скобок

0

Да, именно в таком виде и дано задание.

0

Хорошо, ожидайте

Дано ответов: 2
0 голосов

Ответ:

var x:integer; y:real;

begin

readln (x);

y:=x+2.5;

y:=y*x;

y:=y-1;

y:=y*x;

y:=y+1;

writeln (y);

end.

(18 баллов)
0 голосов

Ответ:

program z1;

var x: integer;

y: real;

begin

read(x);

y:=2*sin(3*x-12*x);

writeln('y равен: ', y);

end.

Либо

program z1;

var x: integer;

y: real;

begin

read(x);

y:=2*(sin3*x)-12*x;

writeln('y равен: ', y);

end.

Объяснение:

Написал 2 варианта, поскольку формула дана вам была не до конца. В ней скорее всего должны стоять где-то скобки. Если нет, то запишите эту же программу (из любых), только уберите в формуле скобки. Надеюсь объяснил понятно

Вариант по той формуле, как она дана (как я её понял

program z1;

var x: integer;

y: real;

begin

read(x);

y:=2*sin(3*x)-12*x;

writeln('y равен: ', y);

end.

(22 баллов)
0

Вот вариант, если без скобок должно быть:

0

Прикреплю его в объяснении