Написать программу, в которой осуществляется ввод целых чисел(ввод до тех пор, пока не...

0 голосов
182 просмотров

Написать программу, в которой осуществляется ввод целых чисел(ввод до тех пор, пока не будет введен ноль) и подсчет суммы введенных положительных чисел. Сделать блок схемой(даю 30 баллов)


Информатика (12 баллов) | 182 просмотров
Дан 1 ответ
0 голосов

Ответ:

Добрый вечер. (ночи :) )

Сделать схемкой не могу но вот написал прогу. Надеюсь поможет. Сейчас попробую сделать схему, но не обещаю удачи.

(P.S. Протестил)

var a,sum:integer;

begin

 sum:=0;

 repeat

    readln(a);

    if a>0 then  

    begin

       sum:=sum+a;

    end;

 until a = 0;

 writeln('Сумма ',sum:5);

end.

Объяснение:

(18 баллов)
0

На какой проге ты это делал?

0

Pascal ABC

0

На телефоне или на компе?

0

На компьютере

0

Мы в школе не делали блок-схем (зато писали кучу программ) так что опишу подробнее что делается может тебе будет проще.

0

var a,sum:integer; (создаю переменные)
begin (Начало(в блок схеме вроде овал) )
sum:=0; (Ввод данных (параллелограмм) )
repeat (запуск цикла (ромб))
readln(a); (Ввод с клавиатуры (параллелограмм))
if a>0 then (Цикл условие if (ромб))
begin (Начало подпрограммы)
sum:=sum+a; (Обработка данных(прямоугольник))
end; (Конец)
until a = 0; (Проверка и часть цикла repeat(стрелкой проведешь на схеме к фигуре repeat)
writeln('Сумма ',sum:5); (Вывод на экран)
end. (Конец основной программы)

0

Я сделал всё что мог удачи.

0

Спасибо