Написать программу в паскаль и Нарисовать Блок - Схему Даю 30б., пжлст

0 голосов
29 просмотров

Написать программу в паскаль и Нарисовать Блок - Схему Даю 30б., пжлст


image

Информатика (81 баллов) | 29 просмотров
Дан 1 ответ
0 голосов

Ответ:

готово. PascalABC

Объяснение:

program tri_chisla;

var n1, n2, n3: real;

begin

 WriteLn('Ввод трех чисел и расположение их в убывающем порядке с заменой значений.');

 Write('Введите значения n1, n2 и n3 через пробел >>> ');

 ReadLn(n1, n2, n3);

 if n1 < n2 then Swap(n1, n2);

 if n2 < n3 then Swap(n2, n3);

 if n1 < n2 then Swap(n1, n2);

 WriteLn('n1=',n1,' n2=',n2,' n3=',n3);

end.

program func_L;

var

 l: real;

 x, y, z: integer;

begin

 repeat

   WriteLn('Введите значения x, y и z');

   Write('Условие: (x-y-z) должно быть больше 0 >>');

   ReadLn(x, y, z);

 until (x - y - z) > 0;

 l := x * y * z - ((abs(x)+abs(y)+abs(z))/(2 * sqrt(x - y - z)));

 WriteLn('L = ', l);

end.

program chislo_a;

var

  a: integer;

begin

 Write('Введите число a >> ');

 ReadLn(a);

 if a >= 0 then WriteLn('Больше или равно нулю')

 else WriteLn('Меньше нуля');

end.


image
image
image
(1.1k баллов)
0

О спасибо большое мозг, выручил

0

Эт кст, мозг, хотел спросить а во 2 задаче обязательно должно быть условие просто в условии не вижу его?

0

ну тоесть во 2 задаче должно быть условие или не?

0

не обязательно, но так правильно: нужно ошибки исключать, поскольку подкоренное выражение не может быть меньше нуля и на ноль делить нельзя

0

а ладно спасиб, мозг

0

Мозг, можешь с задачей по инфе помочь? в профиле чекни у меня самая 1 запись.