Напишите программу ** языке Паскаль, которая при вводе положительного числа утраивает его...

0 голосов
57 просмотров

Напишите программу на языке Паскаль, которая при вводе положительного числа утраивает его значение, при вводе отрицательного числа увеличивает его на 10 единиц, при вводе 0 уменьшает его на 2 единицы.


Информатика (26 баллов) | 57 просмотров
Дан 1 ответ
0 голосов

Ответ:

pascal

Объяснение:

program prog1;

var

 a: real;

begin

 Write('Введите число ');

 ReadLn(a);

 if a > 0 then a := a *3

 else if a < 0 then a := a + 10

 else a := a - 2;

 Write('a = ', a);

end.

(1.0k баллов)