Запишите ** языке Паскаль программы решения задач № 25-30 из & 2.4. Используйте оператор...

0 голосов
839 просмотров

Запишите на языке Паскаль программы решения задач № 25-30 из & 2.4. Используйте оператор while. 25) Напишите алгоритм, под управлением которого Робот обойдет прямоугольную область, обнесённую стеной, по периметру и закрасит угловые клетки. Размеры области неизвестны. 26) Запас рыбы в пруду оценен в А тонн. Ежегодный прирост рыбы составляет 15%. Ежегодный план отлова — В тонн. Наименьший запас рыбы составляет С тонн. (Запас ниже С тонн уже не восстанавливается.) Составьте программу для подсчёта количества лет, в течение которых можно выдерживать заданный план. 27) Дана последовательность 5, 9, 13, 17, … . Составьте программу для определения числа слагаемых, сумма которых равна 324. 28) Составьте программу для определения количества цифр в записи произвольного натурального числа. 29) Сумма 10000 рублей положена в сберегательный банк, при этом прирост составляет 5% годовых. Составьте программу, определяющую, через какой промежуток времени первоначальная сумма увеличиться в 2 раза. 30) Одноклеточная амёба каждые 3 часа делится на 2 клетки. Составьте алгоритм вычисления времени, через которое будет X амёб.


Информатика (71 баллов) | 839 просмотров
Дан 1 ответ
0 голосов

Объяснение:

1 задача

program raf105;

var

b,c,let: integer;

a: real;

begin

write(‘Запас рыбы в пруду: ‘);

readln(a);

write(‘Ежегодный план отлова: ‘);

readln(b);

write(‘Наименьший запас: ‘);

readln(c);

while a >= c do

begin

let+= 1;

a:= a+a/100*15;

a-= b;

end;

writeln(‘Заданный план можно выдержать в течении ‘,let,’ лет.’);

end.

2 задача

program raf105;

var a,sum,counter: integer;

begin

a:=1;

while sum<>324 do

begin

a+= 4;

sum+= a;

counter+= 1;

end;

writeln(‘Число слагаемых: ‘,counter);

end.

3 задача

program raf105;

var a,counter: integer;

begin

write(‘Введите число: ‘);

readln(a);

while a<>0 do

begin

counter+= 1;

a:= a div 10

end;

writeln(‘Количество цифр: ‘,counter);

end.

4 задача

program raf105;

var

a: real;

let:integer;

begin

a:= 10000;

while a<20000 do</p>

begin

let+=1;

a+= a/100*5;

end;

writeln(‘Сумма увеличится в 2 раза через ‘,let,’ лет’);

end.

(68 баллов)