Написать 3 программы: 1.Написать программу, которая будет считать сумму введенных с...

0 голосов
21 просмотров

Написать 3 программы: 1.Написать программу, которая будет считать сумму введенных с клавиатуры чисел до тех пор, пока не будет введен ноль. 2.Написать программу (с циклом While) которая находит сумму всех четных чисел до 100. 3.Написать программу вывода квадратов всех натуральных чисел, не превосходящих данного числа N. Пример: N=50 | 1 4 9 16 25 36 49 язык Паскаль 8 класс


Информатика (14 баллов) | 21 просмотров
Дан 1 ответ
0 голосов

1 программа:

var a, sum:integer;

begin

writeln('Введите числа (цифра 0 - выход из программы)');

sum:= 0;

readln(a);

while(a <> 0) do begin

sum:= sum + a;

readln(a);

end;

writeln('Сумма чисел = ', sum);

end.

2 программа:

var a, sum:integer;

begin

a:=0;

while(a <= 100) do begin</p>

if (a mod 2 = 0) then

 sum:= sum + a;

a:= a + 1;

end;

writeln('Сумма четных чисел = ', sum);

end.

3 программа:

var a, i, N:integer;

begin

writeln('Введите N');

readln(N);

a:=1;

for i:=1 to N do begin

 write(a*a, ' ');

 a:= a + 1;

end;

end.

(294 баллов)