Помогите, срочно нужна помощь Составить программу. Из 800 учащихся школы ** данный...

0 голосов
57 просмотров

Помогите, срочно нужна помощь Составить программу. Из 800 учащихся школы на данный момент посещают школу N человек. Определить, через сколько дней число посещающих школу составит менее половины учащихся школы, если число не больных школьников каждый день уменьшается на 10% от предыдущего дня.


Информатика (112 баллов) | 57 просмотров
Дан 1 ответ
0 голосов

#include

using namespace std;

signed main() {

   const int full = 800;

   int n;

   cin >> n;

   int ans = 0;

   while(n >= full/2)

   {

       n -= n/10;

       ans++;

   }

   cout << ans;</strong>

}

(688 баллов)
0

а какой еще?)

0

что за знак после строки с while, похожий на фигурную скобку

0

?????

0

фигурная скобка)

0

Блин, у нас на дистационном обучении такие похожие программы не деалют. Но все равно спасибо))))

0

у вас, наверное, Паскаль, я угадал?

0

Даааа, и вот на этом Д.О вообще ничего не понимаешь и страдаешь сидишь над учебником, но бестолку

0

соболезную, что паскаль, это прям бесполезный язык, который давно себя изжил, если планируете связывать будущее с этой сферой, то бросайте его нафиг и учите python, java или с++,сдавая школьные работы на одном из этих языков, если нет, то уж отмучайтесь как-нибудь и забудьте как страшный сон

0

Спасибо за совет))

0

Не поможешь еще с почти таким же заданием???