Напишите программу ** языке Phyton!ДАЮ 100 БАЛЛОВ100 БАЛЛОВ​

0 голосов
80 просмотров

Напишите программу на языке Phyton!ДАЮ 100 БАЛЛОВ100 БАЛЛОВ​


image

Информатика (24 баллов) | 80 просмотров
Дано ответов: 2
0 голосов

Ответ:

a = int(input ('Введите номер месяца:'))

if a == 1 or a == 2 or a == 12:

   print ('Зима')

elif a == 3 or a == 4 or a == 5:

   print ('Весна')

elif a == 6 or a == 7 or a == 8:

   print ('Лето')

elif a == 9 or a == 10 or a == 11:

   print ('Осень')

else:

   print ('Неверный номер месяца')

Объяснение:

(165 баллов)
0 голосов

Ответ:

import locale

locale.setlocale(locale.LC_ALL, 'ru_RU.UTF-8')

myDate = datetime.today()

myMonth = myDate.strftime('%B')

Ещё можно вот так через функции:

def month_name(num, lang):

   en = ['january', 'february', 'march', 'april', 'may', 'june', 'july', 'august', 'september',

         'october', 'november', 'december']

   ru = ['январь', 'февраль', 'март', 'апрель', 'май', 'июнь', 'июль', 'август', 'сентябрь',

         'октябрь', 'ноябрь', 'декабрь']

   if lang == 'en':

       return en[num - 1]

   else:

       return ru[num - 1]

Объяснение:

(66 баллов)