Помогите с информатикой Дан массив, состоящий из N целых чисел, количество элементов...

0 голосов
56 просмотров

Помогите с информатикой Дан массив, состоящий из N целых чисел, количество элементов вводится с клавиатуры. Составить программу, в которой будут реализованы следующие действия: а) заполнение массива случайными числами и вывод полученного массива на экран; б) подсчет количества тех элементов массива, значения которых больше заданного числа x (вводит пользователь с клавиатуры) и одновременно кратны 5;​


Информатика (436 баллов) | 56 просмотров
0

какой язык программирования использовать?

0

Pascal

Дан 1 ответ
0 голосов

// PascalABC.Net

var a: array of integer;

N, i, x, count: integer;

begin

   write('Введите размер массива: ');

   readln(N);

   SetLength(a, N);

   

   for i := 0 to N - 1 do

   begin

       a[i] := random(-20, 20);

       write(a[i], ' ');

   end;

   writeln();

   

   write('Введите x: ');

   readln(x);

   for i := 0 to N - 1 do

   begin

       if (a[i] > x) and (a[i] mod 5 = 0) then

           inc(count);

   end;

   writeln('Кол-во подсчитанных элементов: ', count);

end.

(4.3k баллов)
0

Спасибо большое