ПОМОГИТЕ! ПРОШУУУ!! ДАЮ 33 БАЛЛА Написать программу ** языке PASCAL, которая в массиве...

0 голосов
20 просмотров

ПОМОГИТЕ! ПРОШУУУ!! ДАЮ 33 БАЛЛА Написать программу на языке PASCAL, которая в массиве размером 30 со случайными числами ищет нечетные числа и выводит на экран их кол-во.


Информатика (16 баллов) | 20 просмотров
Дано ответов: 2
0 голосов

program answer;

uses CRT;

Var  

a: array [1..30] of integer;

i: integer; n:integer;

begin

clrscr;

for i:=1 to 30 do begin

a[i]:= random(100);

writeln (a[i]);

end;

Writeln ('chetnie chisla s massiva: ');

   for i:=1 to 30 do

       begin

       if ((a[i]) mod 2 = 0) then writeln (a[i])

       end;

end.

(104 баллов)
0 голосов

// PascalABC.NET

begin

 var a := ArrRandom(30, -99, 99);

 a.Println.Count(p -> p.IsOdd).Print

end.


image
(1.6k баллов)