Напишите программу в Pascal, которая выводит наименьшую из четырех величин a,b,c,d.

0 голосов
177 просмотров

Напишите программу в Pascal, которая выводит наименьшую из четырех величин a,b,c,d.


Информатика (76 баллов) | 177 просмотров
Дан 1 ответ
0 голосов

programm Z1;

var a, b, c,d:integer;

begin

writeln ('Введите четыре числа');

readln (a, b, c, d);

If a>b, a>c, a>d then

e:=a;

If b>a, b>c,b>d then

e:=b;

If c>a, c>b, c>d then

e:=c;

If d>a,d>b, d>c then

e:=d;

writeln ('Наибольшое число -',e);

end.

(240 баллов)
0

Можно лучший ответ