7. ** вход программе подается натуральное число. Каких цифр в числе больше четных или...

0 голосов
64 просмотров

7. На вход программе подается натуральное число. Каких цифр в числе больше четных или нечетных. В ответ выведите 1, если больше нечетных и 0, если четных и 2, если их количество одинаково.Питон помогите плиз​


Информатика (44 баллов) | 64 просмотров
Дан 1 ответ
0 голосов

num = input()

n = len(num)

odd = 0

noodd = 0

while i < len(num):

   if(int(num[i]) % 2 == 0):

       odd = odd + 1

   else :

       noodd = noodd + 1

if(odd == noodd):

   print(2)

elif(odd > noodd):

   print(0)

else :

   print(1)

(42 баллов)
0

цикл с предусловием ?

0

он тут есть

0

for i in range(n):

0

могу сделать через while

0

Что за нод

0

да давай через вайл

0

проверь

0

я изменил

0

жду спасибо ))

0

спасибо