Срочно. Помогите пожалуйста по информатике 1. Сколько чисел от 1 до 100 удовлетворяю...

0 голосов
46 просмотров

Срочно. Помогите пожалуйста по информатике 1. Сколько чисел от 1 до 100 удовлетворяю условию:(x div 10 = 0) or ((x mod 10 = 0) and (x >80 ))? 2. Определите значение переменной c после выполнения следующего фрагмента программы. a := 15; b := 23;b := - a / 4* b; if a < b then c := b - a else c := a - 4 * b; 3. Написать программу для определения площади Прямоугольного треугольника и его периметра .Через тип данных longint, максимум 6 строк Даю 20 баллов


Информатика (14 баллов) | 46 просмотров
Дан 1 ответ
0 голосов

1)  11 чисел: 1 - 9, 90, 100.

2) 360.

3)

program Triangle;

var a : LongInt;

   b : LongInt;

   c : LongInt;

begin

   writeln('Введите стороны a, b, c, попорядку.');

   readln(a);

   readln(b);

   readln(c);

   writeln('Площадь: ', 0.5 * a * b, '. Периметр = ', a + b + c, '.')

end.

(528 баллов)