Написать программу, которая считает сумму квадратов первых n натуральных чисел. плиз...

0 голосов
33 просмотров

Написать программу, которая считает сумму квадратов первых n натуральных чисел. плиз очень нужно


Информатика (32 баллов) | 33 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
i,n,x:integer;
begin
readln(n);
for i:=1 to n do
x:=x+sqr(i);
writeln(x);
end.


Надеюсь на Лучший ответ ;)

(1.2k баллов)
0

Хоть мы в интернете и друг друга не знаем и не видим, но правила хорошего тона еще никто не отменял, поэтому выбирайте выражения при общении. Я с вами спорить не буду, но я права, указав на вашу ошибку.

0

Ладно извените просто сорвался от такой неграмотности, я просто решил облегчить код, а мне говорят 2+2=6

0

Если вы не участвовали в олимпиадах, в которых из-за того, что у вас нет обнуления счетчика, вам обнуляют баллы, то конечно же вам этого не понять.

0

И да это не весомая ошибка, ибо ее можно проапеллировать.

0

Бахахахах это вы говорите призёру окружного этапа

0

Я рад за вас, но вы не задумываетесь, что в России много округов и Всероссийская олимпиада проходит не только у вас?

0

Ну учитывая, что я живу в Москве....

0

Я просто говорю, как проверяют у нас и вам на заметку.

0

Ладно спор себя исчерпал, моя программа работает всегда верно, и если гдето на олимпиадах ставят дополнительные условия это уже совсем другая история

0

Ну наконец-то, все решилось мирным путем...