Составьте программу в PascalABC, которая печатает в первой строке два знака '& &' через...

0 голосов
65 просмотров

Составьте программу в PascalABC, которая печатает в первой строке два знака '& &' через один пробел, во второй – через два пробела '& &', в третьей - '& &' через три пробела, ..., в строке с номером 9 - & (через 9 пробелов) & . Печать строки оформить через процедуру. Число строк вводить с клавиатуры.


Информатика (124 баллов) | 65 просмотров
Дан 1 ответ
0 голосов

// PascalABC.NET

procedure MadPrt(n: integer) := Writeln('&' + n * ' ' + '&');

begin

 var n := ReadInteger('Сколько нужно строк?');

 for var i := 1 to n do

   MadPrt(i)

end.


image
(1.6k баллов)