В заданном одномерном массиве поменять местами соседние элементы. Напишите программу **...

0 голосов
75 просмотров

В заданном одномерном массиве поменять местами соседние элементы.

Напишите программу на Паскале, заранее спасибо!


Информатика (12 баллов) | 75 просмотров
Дан 1 ответ
0 голосов

Var
  n, i, c : integer;
  a : array [1..1000] of integer;
begin
  read (n);
   for i := 1 to n do read (a[i]);
  for i := 1 to n div 2 do
  begin
    c := a[i*2];
    a[i*2] := a[i*2-1];
    a[i*2-1] := c;
  end;
  for i := 1 to n do
    write (a[i], ' ');
end.

(4.6k баллов)