Даю 20 баллов Напишите программу, вычисляющую значение функции: y = -1 при x0

0 голосов
193 просмотров

Даю 20 баллов Напишите программу, вычисляющую значение функции: y = -1 при x<0 0 при x=0 1 при x>0


Информатика (12 баллов) | 193 просмотров
Дан 1 ответ
0 голосов

Ответ:

В условии опечатка: два раза написано x < 0.

1) Если функция имеет вид y = 1 при x > 0, 0 при x = 0, -1 при x < 0:

var

  x: real;

  y: integer;

begin

  readln(x);

  if x > 0 then

    y := 1

  else if x = 0 then

    y := 0

  else

    y := -1;

  writeln(y)

end.

2) Если функция имеет вид y = 1 при x < 0, 0 при x = 0, -1 при x > 0, надо просто поменять местами 1 и -1 в решении выше.

(54 баллов)