Помогите пожалуйста по ИНФОРМАТИКЕ Дан массив С, состоящий не более чем из 15 целых...

0 голосов
96 просмотров

Помогите пожалуйста по ИНФОРМАТИКЕ Дан массив С, состоящий не более чем из 15 целых чисел. Написать программу, которая: 1. вводит элементы массива с клавиатуры; 2. находит среднее арифметическое элементов больших 20; 3. находит количество положительных элементов массива; 4. находит минимальный элемент.


Информатика (41 баллов) | 96 просмотров
0

Я так понимаю язык программирования си?

0

Да

0

Окей

0

Спасибо заранее

0

Было бы за что

Дан 1 ответ
0 голосов

#include

#include

#include

#define N 15

int main()

{

   int mas[N];

   int i;

   

   for (i = 0; i < N; i++)

   {

       printf("mas[%d] = ", i+1);

       scanf("%d", &mas[i]);

   }

   

   int count = 0, sum = 0, count1 = 0, min = INT_MAX;

   

   for(int i=0; i

   {

       if (mas[i] > 20)

       {

           sum += mas[i];

           count++;

       }

       

       if(mas[i]>=0)

           count1++;

           

       if(mas[i]

           min = mas[i];

   }

   

   sum = sum / count;

   printf("Средне арифметическое элементов больше 20: %d  ", sum);

   printf("\n");

   printf("Положительных: %d  ", count1);

   printf("\n");

   printf("Минимальный: %d  ", min);

   printf("\n");

   

   getch();

   return 0;

}


image
Скачать вложение Текст (TXT)
(4.0k баллов)