Напишите программу,которая вычисляет сумму: 1) квадратов первых n натуральных чисел.( 2...

0 голосов
57 просмотров

Напишите программу,которая вычисляет сумму: 1) квадратов первых n натуральных чисел.( 2 способами:фор и вайл) 2)всех чётных чисел в диапазоне от 1 до n.( 3 способами:фор ,вайл и интежер)Паскаль.Заранее спасибо 100 б


Информатика (20 баллов) | 57 просмотров
Дан 1 ответ
0 голосов

Ответ:

A) var s, i, n :integer;

begin

s:=0;

readln(n);

for i:= 1 to n do s:=s+i;

writeln(s);

end.

б) var s, i, n :integer;

begin

s:=0;

readln(n);

for i:= 1 to n do s:=s+(i*i);

writeln(s);

end.

в) var s, i, n :integer;

begin

s:=0;

readln(n);

for i:= 1 to n do

begin

if (i mod 2 = 0) then s:=s+i;

end;

writeln(s);

end.

г) var s, i :integer;

begin

s:=0;

for i:= 10 to 99 do s:=s+i;

writeln(s);

end.

Объяснение:

g

(54 баллов)